CRON(8)									       Cronie Users' Manual									   CRON(8)



NAME
       crond - daemon to execute scheduled commands

SYNOPSIS
       crond [-n | -p | -s | -c | -m]

       crond -x [ext,sch,proc,pars,load,misc,test,bit]

DESCRIPTION
       Cron is started from /etc/rc.d/init.d or /etc/init.d It returns immediately, thus, there is no need to need to start it with the '&' parameter.

       Cron  searches  /var/spool/cron	for  crontab  files  which are named after accounts in /etc/passwd; The found crontabs are loaded into the memory.  Cron also searches for
       /etc/anacrontab and any files in the /etc/cron.d directory, which have a different format (see crontab(5)).  Cron examines all stored crontabs and checks each job  to  see
       if  it needs to be run in the current minute. When executing commands, any output is mailed to the owner of the crontab (or to the user specified in the MAILTO environment
       variable in the crontab, if such exists).  Any job output can also be sent to syslog by using the -s option.

       There are two ways how changes in crontables are checked. The first method is checking the modtime of a file. The second method is using the  inotify  support.	 Using	of
       inotify	is  logged  in	the /var/log/cron log after the daemon is started. The inotify support checks for changes in all crontables and accesses the hard disk only when a
       change is detected.

       When using the modtime option, Cron checks its crontables' modtimes every minute to check for any changes and reloads the crontables which have changed. There is  no  need
       to restart Cron after some of the crontables were modified. The modtime option is also used when inotify can not be initialized.

       Cron checks these files and directories: /etc/anacrontab system crontab, usually used to run daily, weekly, monthly jobs. See anacrontab(5) for more details.  /etc/cron.d/
       directory that contains system cronjobs stored for different users.  /var/spool/cron directory that contains user crontables created by the crontab command.

       Note that the crontab(1) command updates the modtime of the spool directory whenever it changes a crontab.

   Daylight Saving Time and other time changes
       Local time changes of less than three hours, such as those caused by the Daylight Saving Time changes, are handled in a special way.  This only applies to jobs that run at
       a specific time and jobs that run with a granularity greater than one hour. Jobs that run more frequently are scheduled normally.

       If  time	 was  adjusted	one  hour forward, those jobs that would have run in the interval that has been skipped will be run immediately.  Conversely, if time was adjusted
       backward, running the same job twice is avoided.

       Time changes of more than 3 hours are considered to be corrections to the clock or the timezone, and the new time is used immediately.

       It is possible to use different time zones for crontables. See crontab(5) for more information.

   PAM Access Control
       Cron supports access control with PAM if the system has PAM  installed.	For  more  information,	 see  pam(8).	A  PAM	configuration  file  for  crond	 is  installed	in
       /etc/pam.d/crond.  The daemon loads the PAM environment from the pam_env module. This can be overridden by defining specific settings in the appropriate crontab file.

OPTIONS
       -m     This  option  allows you to specify a shell command to use for sending Cron mail output instead of using sendmail(8) This command must accept a fully formatted mail
	      message (with headers) on standard input and send it as a mail message to the recipients specified in the mail headers. Specifying the string  off  (i.e.	 crond	-m
	      off) will disable the sending of mail.

       -n     Tells the daemon to run in the foreground. This can be useful when starting it out of init.

       -p     Allows Cron to accept any user set crontables.

       -c     This option enables clustering support, as described below.

       -s     This  option  will  direct  Cron to send the job output to the system log using syslog(3).  This is useful if your system does not have sendmail(8), installed or if
	      mail is disabled.

       -x     This option allows you to set debug flags.

SIGNALS
       When the SIGHUP is received, the Cron daemon will close and reopen its log file.	 This proves to be useful in scripts which rotate and age log files.  Naturally,  this	is
       not relevant if Cron was built to use syslog(3).

CLUSTERING SUPPORT
       In  this	 version  of  Cron  it is possible to use a network-mounted shared /var/spool/cron across a cluster of hosts and specify that only one of the hosts should run the
       crontab jobs in this directory at any one time. This is done by starting Cron with the -c option, and have the /var/spool/cron/.cron.hostname file contain just	one  line,
       which  represents  the  hostname	 of whichever host in the cluster should run the jobs.	If this file does not exist, or the hostname in it does not match that returned by
       gethostname(2), then all crontab files in this directory are ignored.  This has no effect on cron jobs specified in the /etc/crontab file or on files  in  the  /etc/cron.d
       directory. These files are always run and considered host-specific.

       Rather than editing /var/spool/cron/.cron.hostname directly, use the -n option of crontab(1) to specify the host.

       You should ensure that all hosts in a cluster, and the file server from which they mount the shared crontab directory, have closely synchronised clocks, e.g. using ntpd(8)
       , otherwise the results will be very unpredictable.

       Using cluster sharing automatically disables inotify support, because inotify cannot be relied on with network-mounted shared file systems.

CAVEATS
       All crontab files have to be regular files or symlinks to regular files, they must not be executable or writable for anyone else but the owner.	This  requirement  can	be
       overridden  by  using  the  -p option on the crond command line.	 If inotify support is in use, changes in the symlinked crontabs are not automatically noticed by the cron
       daemon. The cron daemon must receive a SIGHUP signal to reload the crontabs.  This is a limitation of the inotify API.

       The syslog output will be used instead of mail, when sendmail is not installed.

SEE ALSO
       crontab(1), crontab(5), inotify(7), pam(8)

AUTHOR
       Paul Vixie 
       Marcela Mašláňová 
       Colin Dean 



Marcela Mašláňová								     July 2010										   CRON(8)
SCP(1)									    BSD General Commands Manual									    SCP(1)

NAME
     scp — secure copy (remote file copy program)

SYNOPSIS
     scp [-12346BCpqrv] [-c cipher] [-F ssh_config] [-i identity_file] [-l limit] [-o ssh_option] [-P port] [-S program] [[user@]host1:]file1 ... [[user@]host2:]file2

DESCRIPTION
     scp copies files between hosts on a network.  It uses ssh(1) for data transfer, and uses the same authentication and provides the same security as ssh(1).	 Unlike rcp(1),
     scp will ask for passwords or passphrases if they are needed for authentication.

     File names may contain a user and host specification to indicate that the file is to be copied to/from that host.	Local file names can be made explicit using absolute or
     relative pathnames to avoid scp treating file names containing ‘:’ as host specifiers.  Copies between two remote hosts are also permitted.

     The options are as follows:

     -1	     Forces scp to use protocol 1.

     -2	     Forces scp to use protocol 2.

     -3	     Copies between two remote hosts are transferred through the local host.  Without this option the data is copied directly between the two remote hosts.  Note that
	     this option disables the progress meter.

     -4	     Forces scp to use IPv4 addresses only.

     -6	     Forces scp to use IPv6 addresses only.

     -B	     Selects batch mode (prevents asking for passwords or passphrases).

     -C	     Compression enable.  Passes the -C flag to ssh(1) to enable compression.

     -c cipher
	     Selects the cipher to use for encrypting the data transfer.  This option is directly passed to ssh(1).

     -F ssh_config
	     Specifies an alternative per-user configuration file for ssh.  This option is directly passed to ssh(1).

     -i identity_file
	     Selects the file from which the identity (private key) for public key authentication is read.  This option is directly passed to ssh(1).

     -l limit
	     Limits the used bandwidth, specified in Kbit/s.

     -o ssh_option
	     Can be used to pass options to ssh in the format used in ssh_config(5).  This is useful for specifying options for which there is no separate scp command-line flag.
	     For full details of the options listed below, and their possible values, see ssh_config(5).

		   AddressFamily
		   BatchMode
		   BindAddress
		   ChallengeResponseAuthentication
		   CheckHostIP
		   Cipher
		   Ciphers
		   Compression
		   CompressionLevel
		   ConnectionAttempts
		   ConnectTimeout
		   ControlMaster
		   ControlPath
		   ControlPersist
		   GlobalKnownHostsFile
		   GSSAPIAuthentication
		   GSSAPIDelegateCredentials
		   HashKnownHosts
		   Host
		   HostbasedAuthentication
		   HostKeyAlgorithms
		   HostKeyAlias
		   HostName
		   IdentityFile
		   IdentitiesOnly
		   IPQoS
		   KbdInteractiveAuthentication
		   KbdInteractiveDevices
		   KexAlgorithms
		   LogLevel
		   MACs
		   NoHostAuthenticationForLocalhost
		   NumberOfPasswordPrompts
		   PasswordAuthentication
		   PKCS11Provider
		   Port
		   PreferredAuthentications
		   Protocol
		   ProxyCommand
		   PubkeyAuthentication
		   RekeyLimit
		   RhostsRSAAuthentication
		   RSAAuthentication
		   SendEnv
		   ServerAliveInterval
		   ServerAliveCountMax
		   StrictHostKeyChecking
		   TCPKeepAlive
		   UsePrivilegedPort
		   User
		   UserKnownHostsFile
		   VerifyHostKeyDNS

     -P port
	     Specifies the port to connect to on the remote host.  Note that this option is written with a capital ‘P’, because -p is already reserved for preserving the times
	     and modes of the file in rcp(1).

     -p	     Preserves modification times, access times, and modes from the original file.

     -q	     Quiet mode: disables the progress meter as well as warning and diagnostic messages from ssh(1).

     -r	     Recursively copy entire directories.  Note that scp follows symbolic links encountered in the tree traversal.

     -S program
	     Name of program to use for the encrypted connection.  The program must understand ssh(1) options.

     -v	     Verbose mode.  Causes scp and ssh(1) to print debugging messages about their progress.  This is helpful in debugging connection, authentication, and configuration
	     problems.

EXIT STATUS
     The scp utility exits 0 on success, and >0 if an error occurs.

SEE ALSO
     rcp(1), sftp(1), ssh(1), ssh-add(1), ssh-agent(1), ssh-keygen(1), ssh_config(5), sshd(8)

HISTORY
     scp is based on the rcp(1) program in BSD source code from the Regents of the University of California.

AUTHORS
     Timo Rinne 
     Tatu Ylonen 

BSD										   May 19, 2015										       BSD



SEARCH and Navigation TOOL
Google     select a domain to search or visit.
(use back key to return )

johnmeister.com/jeep/sj

FULL SIZE JEEPS
JeepMeister
"Jeep is America's
only real sports car."
-Enzo Ferrari
JohnMeister.com- fotos LinuxMeister- CS
MeisterTech- Diesels FotoMeister.us- fotos
BibleTech- Bible Overview search the the internet
Everett weather - Seattle traffic - pollen count -
NEWS: BBC: Middle East - Israel - Spiegel
NASB/KJV/ES/D - SE Asian Missions - jihad - persecution info
e-books by john:

AMSOIL product guide,
AMSOIL web, or 1-800-956-5695
use customer #283461

Amsoil dealer since 1983

CAMERAS: Nikon Lumix Canon DSLRs Lenses
Computers: Toshiba Toughbook Apple Dell
BOOKS: Auto Repair Diesels BioDiesel
PARTS: Wagoneer J-truck Benz VW
books and computers


SJ - 1962-1991

XJ - 1984-2001

WJ - 1999-2004

KJ - 2002-2007

WK - 2005-2010

Find the recommended
AMSOIL synthetics
for your Jeep

CJ-10A - 1984-1986

Jeepsters

MJ - 1984-1992

Willys - 1946-1965

Other Jeeps (FC)